POJ 3280 - Cheapest Palindrome - [区间DP]

题目链接:http://poj.org/problem?id=3280

Time Limit: 2000MS Memory Limit: 65536K

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:

给出n个字母,一个长度为m的字母串(字母都是从n个字母中挑);

然后给出每个字母的添加删除价格,表示添加一个或者删除一个该字母需要花费多少;

求把字母串变成一个回文串的最少花费;

题解:

设dp[0][m-1]为所求答案,且假设当我们求dp[i][j]时,所有的dp[ii][jj](i<ii<jj<j)都是已知的;

那么,有:

if(str[i]==str[j]) dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
dp[i][j]=min(dp[i][j],dp[i][j-1]+min(str[j].add,str[j].del));
dp[i][j]=min(dp[i][j],dp[i+1][j]+min(str[i].add,str[i].del));

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
struct Alpha{
    char ch;
    int add,del;
    int mini(){return min(add,del);}
}alpha[130];
int n,m;
char str[2005];
int dp[2005][2005];

int main()
{
    cin>>n>>m;
    cin>>str;
    for(int i=1;i<=n;i++)
    {
        char c; int add,del;
        cin>>c>>add>>del;
        alpha[c]=(Alpha){c,add,del};
        //printf("%c %d %d\n",alpha[c].ch,alpha[c].add,alpha[c].del);
    }

    memset(dp,INF,sizeof(dp));
    for(int len=0;len<=1;len++)
    {
        for(int i=0,j=i+len-1;j<m;i++,j=i+len-1) dp[i][j]=0;
    }
    for(int len=2;len<=m;len++)
    {
        for(int i=0,j=i+len-1;j<m;i++,j=i+len-1)
        {
            if(str[i]==str[j]) dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
            dp[i][j]=min(dp[i][j],dp[i][j-1]+alpha[str[j]].mini());
            dp[i][j]=min(dp[i][j],dp[i+1][j]+alpha[str[i]].mini());
        }
    }

    cout<<dp[0][m-1]<<endl;
}

 

posted @ 2017-11-23 21:02  Dilthey  阅读(186)  评论(0编辑  收藏  举报