HDU 1021

水题。找规律,从第二开始每四个
/*There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no*/
#include<iostream>
using namespace std;
long long a[1000005];
int main()
{
    int n;
    while(cin>>n)
    {
        if((n-2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
}

一次yes
posted @ 2018-04-14 07:38  MCQ  阅读(82)  评论(0编辑  收藏  举报