紫书 UVA 839

递归求解 非常巧妙
/*The input begins with a single positive integer on a line by itself indicating the number
of the cases following, each of them as described below. This line is followed by a blank
line, and there is also a blank line between two consecutive inputs.
The input is composed of several lines, each containing 4 integers separated by a single space.
The 4 integers represent the distances of each object to the fulcrum and their weights, in the format:
Wl Dl Wr Dr
If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define
the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of
all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the
following lines define two sub-mobiles: first the left then the right one.
Output
For each test case, the output must follow the description below. The outputs of two
consecutive cases will be separated by a blank line.
Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.
Sample Input
1
0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2
Sample Output
YES*/
#include <iostream>
using namespace std;
bool solve(int &w)
{
    bool b1=true,b2=true;
    int w1,w2,d1,d2;
    cin>>w1>>d1>>w2>>d2;
    if(!w1) b1=solve(w1);
    if(!w2) b2=solve(w2);
    w=w1+w2;
    return b1&&b2&&(w1*d1==w2*d2);
}
int main()
{
    int n,w;
    cin>>n;
    while(n--)
    {
        if(solve(w))cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
        if(n)
            cout<<endl;
    }
    return 0;
}

posted @ 2018-04-21 10:28  MCQ  阅读(99)  评论(0编辑  收藏  举报