紫书 UVA699

/*The input contains multiple test cases, each describing a single tree. A tree is specified by giving the
value in the root node, followed by the description of the left subtree, and then the description of the
right subtree. If a subtree is empty, the value ¡®-1¡¯ is supplied. Thus the tree shown above is specified
as ¡®5 7 -1 6 -1 -1 3 -1 -1¡¯. Each actual tree node contains a positive, non-zero value. The last test
case is followed by a single ¡®-1¡¯ (which would otherwise represent an empty tree).
Output
For each test case, display the case number (they are numbered sequentially, starting with 1) on a line
by itself. On the next line display the number of ¡°leaves¡± in each pile, from left to right, with a single
space separating each value. This display must start in column 1, and will not exceed the width of an
80-character line. Follow the output for each case by a blank line. This format is illustrated in the
examples below.
Sample Input
5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1
Sample Output
Case 1:
7 11 3
Case 2:
9 7 21 15*/
#include <iostream>
#include<cstring>
using namespace std;
#define maxn 10000
int sum[maxn];


void build (int p)
{
 int v;
 cin>>v;
 if(v==-1)
    return ;
    sum[p]+=v;
 build(p-1);
 build(p+1);
}
bool init()
{
    int v;
    cin>>v;
    if(v==-1)
        return false;
    int p=maxn/2;
    memset(sum,0,sizeof(sum));
    sum[p]=v;
    build(p-1);
    build(p+1);
}
int main()
{
    int kase=0;
    while(init())
    {
        cout<<"Case "<<++kase<<":"<<endl;
        int p=0;
        while(sum[p]==0) p++;
        cout<<sum[p++];
        while(sum[p]!=0) cout<<" "<<sum[p++];
        cout<<endl<<endl;
    }

    return 0;
}

理解build和init函数就很容易了。


posted @ 2018-04-21 15:56  MCQ  阅读(79)  评论(0编辑  收藏  举报