二叉搜索树的操作集

6-12 二叉搜索树的操作集(30 分)

本题要求实现给定二叉搜索树的5种常用操作。

函数接口定义:

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

其中BinTree结构定义如下:

typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};
  • 函数InsertX插入二叉搜索树BST并返回结果树的根结点指针;
  • 函数DeleteX从二叉搜索树BST中删除,并返回结果树的根结点指针;如果X不在树中,则打印一行Not Found并返回原树的根结点指针;
  • 函数Find在二叉搜索树BST中找到X,返回该结点的指针;如果找不到则返回空指针;
  • 函数FindMin返回二叉搜索树BST中最小元结点的指针;
  • 函数FindMax返回二叉搜索树BST中最大元结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT );  /* 中序遍历,由裁判实现,细节不表 */

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:"); PreorderTraversal(BST); printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        Tmp = Find(BST, X);
        if (Tmp == NULL) printf("%d is not found\n", X);
        else {
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

10
5 8 6 2 4 1 0 10 9 7
5
6 3 10 0 5
5
5 7 0 10 3

输出样例:

Preorder: 5 2 1 0 4 8 6 7 10 9
6 is found
3 is not found
10 is found
10 is the largest key
0 is found
0 is the smallest key
5 is found
Not Found
Inorder: 1 2 4 6 8 9

ANS:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ) /* 先序遍历,由裁判实现,细节不表 */
{
    if(!BT)
    {
        return ;
    }
    printf("%d ",BT->Data);
    PreorderTraversal(BT->Left);
    PreorderTraversal(BT->Right);
}
void InorderTraversal( BinTree BT )  /* 中序遍历,由裁判实现,细节不表 */
{
    if(!BT)
    {
        return ;
    }
    InorderTraversal(BT->Left);
    printf("%d ",BT->Data);
    InorderTraversal(BT->Right);
}
BinTree Insert( BinTree BST, ElementType X )
{
    BinTree t=BST;
    if(!BST)
    {
        BST=(BinTree )malloc(sizeof(struct TNode));
        BST->Data=X;
        BST->Left=NULL;
        BST->Right=NULL;
    }
    if(X<BST->Data)
    {
        BST->Left=Insert(BST->Left,X);
    }
    else if(X>BST->Data)
    {
        BST->Right=Insert(BST->Right,X);
    }
    return BST;
}

Position Find( BinTree BST, ElementType X )
{
    if(BST==NULL||BST->Data==X)
    {
        return BST;
    }
    else if(BST->Data>X)
    {
        return Find(BST->Left,X);
    }
    else if(BST->Data<X)
    {
        return Find(BST->Right,X);
    }
}
Position FindMin( BinTree BST )
{
    if(!BST)
        return NULL;
    while(BST->Left)
    {
        BST=BST->Left;
    }
    return BST;
}
Position FindMax( BinTree BST )
{
    if(!BST)
        return NULL;
    while(BST->Right)
    {
        BST=BST->Right;
    }
    return BST;
}
BinTree Delete( BinTree BST, ElementType X ){
    Position temp,s=BST;
    if(!BST){
        printf("Not Found\n");//如果最终树为空,说明没有
    }
    else{//这里类似于插入重点在于找到后怎么办
        if(X < BST->Data){
            BST->Left = Delete(BST->Left,X);//从左子树递归删除
        }
        else if(X > BST->Data){
            BST->Right = Delete(BST->Right,X);//从右子树递归删除
        }
        else{//当前BST就是要删除的节点
              if(BST->Left && BST->Right){//要被删除的节点有左右两个孩子,就从右子树中找最小的数填充删除的节点
                temp = FindMin(BST->Right);//找最小
                BST->Data = temp->Data;//填充删除的节点
                BST->Right = Delete(BST->Right,temp->Data);//删除拿来填充的那个节点
              }
              else{//只有一个子节点
                temp = BST;
                if(!BST->Left){//只有右节点
                    BST = BST->Right;//直接赋值就可以
                }
                else if(!BST->Right){//只有左节点
                    BST = BST->Left;//直接赋值就可以
                }
                free(temp);//如果啥也没有直接删除就可以,当然上面两种情况赋值后也要删除
              }
        }
    }
    return s;
}
int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:");
     PreorderTraversal(BST);
     printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        Tmp = Find(BST, X);
        if (Tmp == NULL) printf("%d is not found\n", X);
        else {
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}

 

posted @ 2018-08-24 21:08  MCQ  阅读(328)  评论(0编辑  收藏  举报