[HDUOJ1312]Red And Black (经典的DFS)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16129    Accepted Submission(s): 9939


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 

 

Sample Output
45
59
6
13
 
 
 
 
 
 
 
一道很经典的bfs题目,比较简单,适合刚接触dfs的人。
注意:
1.在初始点进行dfs,因为初始点也是一个符合要求的点,所以别忘记了加上。
 
Code:
 
import java.util.Scanner;

public class Main {

    public static int count = 0;

    public static int maxN = 0;

    public static int maxM = 0;

    public static void main( String[] args ) {
        Scanner sc = new Scanner( System.in );
        int n, m;
        while( sc.hasNext() ) {
            count = 0;
            n = sc.nextInt();
            m = sc.nextInt();
            int si = 0;
            int sj = 0;
            if( n == 0 || m == 0 )
                return;
            else {
                maxN = n;
                maxM = m;
                char[][] maps = new char[ m ][ n ];
                for( int i = 0; i < m; i++ ) {
                    String s = sc.next();
                    for( int j = 0; j < s.length(); j++ ) {
                        char c = s.charAt( j );
                        maps[ i ][ j ] = c;
                        if( c == '@' ) {
                            si = i;
                            sj = j;
                        }
                    }
                }
                dfs( maps, si, sj );
                System.out.println( count );
            }
        }
    }

    private static void dfs( char[][] maps, int i, int j ) {
        if( !cons( i, j ) )
            return;
        if( maps[ i ][ j ] == '@' || maps[ i ][ j ] == '.' ) {
            count++;
            maps[ i ][ j ] = '#';
            dfs( maps, i + 1, j );
            dfs( maps, i - 1, j );
            dfs( maps, i, j + 1 );
            dfs( maps, i, j - 1 );
        } else {
            return;
        }
    }

    public static boolean cons( int i, int j ) {
        if( i < 0 || j < 0 || i >= maxM || j >= maxN )
            return false;
        return true;
    }

}

 

 
 
 
 
 
 
 
 
 
 
posted @ 2016-05-10 17:53  hudiwei-hdw  阅读(167)  评论(0编辑  收藏  举报