素数的个数

 

Time Limit: 1 Sec  Memory Limit: 128 MB

 

Submit: 58  Solved: 40
原题链接

 

Description

求正整数M与N之间的所有素数的个数.(M<=N)

Input

输入只有一行,包括2个整数M,N,之间用一个空格分开。

Output

输出只有一行(这意味着末尾有一个回车符号),包括1个整数。

Sample Input

1 20

Sample Output

8

HINT

 

Source

 
#include<iostream>
using namespace std;
main()
{
    int m,n,count=0;
    cin>>m>>n;
    if(m==1)
        m++;
    for(int i=m;i<=n;i++)
    {
        
        int flag=1;
        for(int j=2;j<i;j++)
        {
            if(i%j==0)
            {flag=0;
                break;}
        }
        
        if(flag==1)
        {count++;}
        
    }
    
    cout<<count<<endl;
    
}

 

posted @ 2017-03-17 15:43  dearvee  阅读(230)  评论(0编辑  收藏  举报