Jungle Roads

题目链接

题意

Problem Description

img
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题意

给出各点之间的一些价值,然后用这些点构成一棵最小生成树。

输入:n(点的数量)接下来有n-1行

​ A n1(与A相连的有n1个点) B n2 (与A相连的一个点B 价值是n2)。。。。。

输出构成小生成树的最小价值

分析

和普通的最小生成树没有什么区别,只是这里输入的编号不是数字而是字符,可以利用map来把每一个字符编号。

代码

#include<bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
int n;
int road[27][27];
int dis[27];
int vest[27];
void prime()
{
    for (int i = 1; i <= n; i++)
    {
        dis[i] = road[1][i];
        vest[i] = 0;
    }
    vest[1] = 1;
    int sum = 0;
    int count1 = 1;
    int op = 1;
    while (count1 < n)
    {
        int min1 = inf;
        for (int i = 1; i <= n; i++)
            if (vest[i] == 0 && dis[i] < min1)
            {
                min1 = dis[i];
                op = i;
            }
        vest[op] = 1;
        count1++;
        sum += min1;
        for (int i = 1; i <= n; i++)
            if (vest[i] == 0 && dis[i] > road[op][i])
                dis[i] = road[op][i];
    }
    printf("%d\n", sum);
}
int main()
{
    while (scanf("%d", &n))
    {
        if(n==0)break;
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++)
                if (i != j)road[i][j] = inf;
                else road[i][j] = 0;
        map<char, int>m;
        int k = 0;
        for (int i = 0; i < n - 1; i++)
        {
            char ch;
            int du;
            scanf(" %c %d", &ch, &du);
            if (m[ch] == 0)
            {
                k++;
                m[ch] = k;//给不同的字符进行编号
            }
            for (int j = 0; j < du; j++)
            {
                int value;
                char ch1;
                scanf(" %c %d", &ch1, &value);
                if (m[ch1] == 0)
                {
                    k++;
                    m[ch1] = k;
                }
                road[m[ch]][m[ch1]] = road[m[ch1]][m[ch]] = value;//赋值
            }
        }
        prime();
    }
    return 0;
}
/*
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

*/
posted @ 2017-04-14 12:43  -梦里不知身是客  阅读(177)  评论(0编辑  收藏  举报