胜利大逃亡 三维广搜

题目连接

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 36870    Accepted Submission(s): 13013

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
img

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)
特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

分析

由普通的二维广搜变成三维的广搜

{{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1} }三维的六个方向

代码

#include <iostream>
#include<string.h>
#include<queue>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
using namespace std;
int A,B,C,time;
int palace[55][55][55];
int dir[6][3]= {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1} };//三维的六个方向
struct node
{
    int x;
    int y;
    int z;
    int t;
};
int bfs(int sx,int sy,int sz)
{
    node a,b;
    a.x=sx;
    a.y=sy;
    a.z=sz;
    a.t=0;
    queue<node>q;
    q.push(a);
    palace[sx][sy][sz]=1;//注意将第一个标记
    while(!q.empty())
    {
        a=q.front();
        q.pop();
        if(a.t>=time)continue;//提前结束本次循环
        if(a.x==A-1&&a.y==B-1&&a.z==C-1&&a.t<time)return a.t;
        for(int i=0; i<6; i++)
        {
            int tx=a.x+dir[i][0];
            int ty=a.y+dir[i][1];
            int tz=a.z+dir[i][2];
            if(tx<0||tx>=A||ty<0||ty>=B||tz<0||tz>=C)
                continue;
            if(palace[tx][ty][tz]==0)
            {
                palace[tx][ty][tz]=1;//标记
                b.t=a.t+1;
                b.x=tx;
                b.y=ty;
                b.z=tz;
                q.push(b);
            }
        }
    }
    return -1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d",&A,&B,&C,&time);
        for(int k=0; k<A; k++)
            for(int i=0; i<B; i++)
                for(int j=0; j<C; j++)
                {
                    scanf("%d",&palace[k][i][j]);
                }
        int t=bfs(0,0,0);


          printf("%d\n",t);
    }

    return 0;
}
 

 

posted @ 2017-04-14 12:42  -梦里不知身是客  阅读(177)  评论(0编辑  收藏  举报