Fire Net

题目连接

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11365    Accepted Submission(s): 6796

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 
img
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

题意

同行同列在没有墙阻挡的情况下只能防止一个碉堡,否则他们就会互相攻击,若有墙阻挡,他们就不会互相攻击,问最多能放多少个碉堡

分析

简单的深搜,注意一个允许放置碉堡的位置,也可以选择不放,可能不放这个位置会形成最大放置碉堡数目的情况

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string.h>
using namespace std;
char palace[5][5];
int n;
int max1=-1;
bool isOk(int x,int y)
{
    //因为是从左往右从上向下来放置碉堡的,
    //所以只需判断该位置的左方和上方的情况是否允许该位置放置碉堡
    for(int i=x-1; i>=0; i--)
    {
        if(palace[i][y]=='#')return false;//如果上方有一个碉堡,那么就不能放
        if(palace[i][y]=='X')break;
    }
    for(int i=y-1; i>=0; i--)
    {
        if(palace[x][i]=='#')return false;
        if(palace[x][i]=='X')break;
    }
    return true;
}
void dfs(int counter,int s)//挨个遍历所有的位置,counter是位置的个数
{
    if(counter==n*n)
    {
        if(s>max1)
            max1=s;
        return ;
    }
    int x=counter/n;//行
    int y=counter%n;//列
    if(palace[x][y]=='.'&&isOk(x,y))
    {
        palace[x][y]='#';
        dfs(counter+1,s+1);//允许放置,并且放置了
        palace[x][y]='.';
        dfs(counter+1,s);//允许放置,但是没有放置
}
    
  else   dfs(counter+1,s); //不允许放置
}
int main()
{
    while(scanf("%d",&n),n)
    {
        max1=-1;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                palace[i][j]='X';
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                scanf(" %c",&palace[i][j]);
            }
        dfs(0,0);
        printf("%d\n",max1);
    }
    return 0;
}
posted @ 2017-04-14 12:32  -梦里不知身是客  阅读(139)  评论(0编辑  收藏  举报