ZOJ 3203 Light Bulb

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

 

Input

 

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

<b< dd="">

Output

 

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

此题可以用数学公式直接推出在每种情况下的最值,也可以用三分来做,但都需要把函数式表示出来。

设人在地上的投影的长度为x,在墙上的长度位y。
利用相似三角行将y消元,得到关于y的函数式,对此式用三分(我不知道那么一个式子是怎么看出它的增减性可以用三分的)。
y的定义域为[0,h]。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<stack>
#include<deque>
#include<iostream>
using namespace std;
double H,h,d;
double f(double y)
{
    return (d*h-d*y)/(H-y)+y;
}
void solve(double a,double b)
{
    double mid,left,right;
    double midmid;
    int i,p,j,cal=10000;
    left=a;
    right=b;
    while(cal)
    {

        mid=(left+right)/2;
        midmid=(mid+right)/2;
        if(f(mid)>f(midmid))
            right=midmid;
        else
            left=mid;

            /*
        mid=(a+b)/2;
        midmid=(b+mid)/2;
        if(f(mid)>=f(midmid))
            b=midmid;
        else
            a=mid;*/
        cal--;
    }
    printf("%.3lf\n",f(mid));
}
int main()
{
    int i,p,j;
    int t,n;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        scanf("%lf%lf%lf",&H,&h,&d);
        solve(0,h);
    }
    return 0;
}
View Code

 

posted @ 2018-07-19 17:10  Daybreaking  阅读(187)  评论(0编辑  收藏  举报