HOJ-1005 Fast Food(动态规划)

Fast Food
My Tags (Edit)
Source : Unknown
Time limit : 3 sec Memory limit : 32 M
Submitted : 3777, Accepted : 1147
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.
To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < … < dn (these are the distances measured from the company’s headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.
The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as

must be as small as possible.
Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.
The input file will end with a case starting with n = k = 0. This case should not be processed.
Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.
Output a blank line after each test case.
Sample Input
6 3
5
6
12
19
20
27
0 0
Sample Output
Chain 1
Total distance sum = 8

在写这道题目的时候,有想过dp[i][j],第i个店铺有j个中转站可以获得的最短距离。可是就不知道后面该怎么办了,第i个店铺和第i-1的店铺状态怎么转移。但是如果是第j个中转站和第j-1个中转站呢?这道题目还有一个关键的点从i到j的店铺中,只有一个中转站是最短距离就是中转站在(i+j)/2。

这里写代码片#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>

using namespace std;
#define MAX 1<<30
int dp[205][35];
int c[205][205];
int a[205];
int n,k;
int main()
{
    int cas=0;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n==0&&k==0)
            break;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
                for(int p=i;p<=j;p++)
                    c[i][j]+=abs(a[p]-a[(i+j)/2]);
        for(int i=0;i<=n;i++)
            for(int j=0;j<=k;j++)
                dp[i][j]=MAX;
        dp[0][0]=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<i;j++)
            {
                for(int p=1;p<=k;p++)
                {
                    dp[i][p]=min(dp[i][p],dp[j][p-1]+c[j+1][i]);
                }
            }
        }
        printf("Chain %d\n",++cas);
        printf("Total distance sum = %d\n\n",dp[n][k]);


    }
posted @ 2016-01-16 22:13  Shendu.CC  阅读(95)  评论(0编辑  收藏  举报