HDU 4417 Super Mario(线段树)

Super Mario

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5370    Accepted Submission(s): 2461


Problem Description
Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
 

Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
 

Output
For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
 

Sample Input
1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3
 

Sample Output
Case 1: 4 0 0 3 1 2 0 1 5 1
可持久化线段树,求动态区间比某个值小的有几个。时间限制1秒,所以要离散化,否则会超时也会超内存
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <map>

using namespace std;
typedef long long int LL;
const int maxn=1e5;
int l[maxn*18+5];
int r[maxn*18+5];
int rt[maxn+5];
int num[maxn*18+5];
int p;
int n,m;
int ll,rr;
LL H;
LL a[maxn+5];
LL b[maxn+5];
map<LL,int> mm;
int nownode()
{
    l[p]=r[p]=0;
    num[p]=0;
    return p++;
}
void update(int &node,LL begin,LL end,LL tag)
{
    if(!node) node=nownode();
    else
    {
        num[p]=num[node];l[p]=l[node];
        r[p]=r[node];node=p;
        p++;
    }
    if(begin==end)
    {
         num[node]++;
         return ;
    }
    LL mid=(begin+end)>>1;
    if(tag<=mid) update(l[node],begin,mid,tag);
    else update(r[node],mid+1,end,tag);
    num[node]=num[l[node]]+num[r[node]];
}
int query(int node1,int node2,LL begin,LL end,LL tag)

{
    if(0<=begin&&end<=tag)
    {
        return num[node2]-num[node1];
    }
    LL mid=(begin+end)>>1;
    if(tag<=mid) return query(l[node1],l[node2],begin,mid,tag);
    else return num[l[node2]]-num[l[node1]]+query(r[node1],r[node2],mid+1,end,tag);
}
int bin(LL x)
{
    int l=1;int r=n;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(a[mid]<=x)
            l=mid+1;
        else
            r=mid-1;
    }
    return r;
}
int main()
{
    int t;
    scanf("%d",&t);
    LL len=1e9;
    LL x;
    int cas=0;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(rt,0,sizeof(rt));
        memset(num,0,sizeof(num));
        p=1;
        for(int i=1;i<=n;i++)
        {

            scanf("%lld",&a[i]);
            b[i]=a[i];

        }
        sort(a+1,a+n+1);
        int tot=0;
        mm.clear();
        for(int i=1;i<=n;i++)
            if(!mm[a[i]]) 
                mm[a[i]]=tot++;
        for(int i=1;i<=n;i++)
        {
            update(rt[i]=rt[i-1],0,maxn,mm[b[i]]);
        }
        printf("Case %d:\n",++cas);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%lld",&ll,&rr,&H);
            int x=bin(H);
            if(x==0) {printf("0\n");continue;}
            ll++,rr++;
            printf("%d\n",query(rt[ll-1],rt[rr],0,maxn,mm[a[x]]));
        }
    }
    return 0;
}


 
posted @ 2016-10-30 08:26  Shendu.CC  阅读(100)  评论(0编辑  收藏  举报