练习 简单数塔

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
Output
对于每个测试实例,每行输出最大和。
Sample Input
2
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
3
1
1 1
1 1 1
Sample Output
30
3

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
int a[1000][1000];
int main()
{
    int c;
    scanf("%d",&c);
    while(c--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<=i; j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(int i=n-1;i>=0;i--)
        {
            for(int j=0;j<i;j++)
            {

               a[i-1][j]=max(a[i][j]+a[i-1][j],a[i][j+1]+a[i-1][j]);
            }
        }
        printf("%d\n",a[0][0]);
    }
}
posted @ 2016-11-17 15:50  _大美  阅读(139)  评论(0编辑  收藏  举报