第二十九天

问题描述:实现复数类的运算

输入格式:

输入有两行,分别为两个复数的实部与虚部。

输出格式:

按样例格式输出结果。

输入样例:

在这里给出一组输入。例如:

4 2
3 -5
 

输出样例:

在这里给出相应的输出。例如:

(7, -3)
(1, 7)
(-3, 5)

代码:

#include <iostream>
using namespace std;
class Complex
{
public:
Complex(double r=0, double i=0):real(r), imag(i){ }
Complex operator+(const Complex& c) const;//重载双目运算符'+'
Complex& operator-=(const Complex& c);//重载双目运算符'-='
friend Complex operator-(const Complex& c);//重载一元运算符'-'
friend Complex operator-(const Complex& c1, const Complex& c2);//重载二元运算符'-'
void Display() const;
private:
double real;
double imag;
};

Complex Complex::operator+(const Complex& c) const
{
return Complex(real + c.real, imag + c.imag);
}

Complex& Complex::operator-=(const Complex& c)
{
real -= c.real;
imag -= c.imag;
return *this;
}

Complex operator-(const Complex& c)
{
return Complex(-c.real, -c.imag);
}

Complex operator-(const Complex& c1, const Complex& c2)
{
return Complex(c1.real - c2.real, c1.imag - c2.imag);
}

void Complex::Display() const
{
cout << "(" << real << ", " << imag << ")" << endl;
}

int main()
{
double r, m;
cin >> r >> m;
Complex c1(r, m);
cin >> r >> m;
Complex c2(r, m);
Complex c3 = c1+c2;
c3.Display(); // 输出(7, -3)
c3 = c1-c2;
c3.Display(); // 输出(1, 7)
c3 -= c1;
c3.Display(); // 输出(-3, 5)
return 0;
}

 

posted @   序章0  阅读(18)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 单线程的Redis速度为什么快?
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 展开说说关于C#中ORM框架的用法!
点击右上角即可分享
微信分享提示