ISIS基础实验
ISIS Area
不是ABR将路由转发给内部路由器,而是内部路由器数据库中知道ABR,产生默认路由指向ABR
路由泄漏
Uses up/down bit in Type,Length, and Value (TVL) field:主要up/down bit(U/D Bit)用于避免环路
一旦做了重分布的路由条目都会置up/down bit
如果Up/Down位设置为0,那么说明这条路由就是始发于本地L1区域的
如果Up/Down位设置为1,那么说明这条路由是由L2泄漏到L1的
(路由表中泄漏的路由被标识为“ia”路由,即区域间的路由)
(路由表中泄漏的IPv6地址路由被标识为“IA”路由,即区域间的路由)
R4#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x00000006 0xC431 962 0/0/0
R2.00-00 0x0000000A 0x12CD 1143 0/0/0
R2.02-00 0x00000003 0x71DE 805 0/0/0
R3.00-00 0x0000000C 0x39A5 1152 1/0/0
R3.02-00 0x00000003 0x92B8 1139 0/0/0
R4.00-00 * 0x00000003 0x763E 724 1/0/0
R4.02-00 * 0x00000002 0x81C9 891 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R3.00-00 0x0000000B 0x8C7E 1144 0/0/0
R4.00-00 * 0x00000003 0x4FB4 718 0/0/0
R5.00-00 0x00000003 0x540E 908 0/0/0
R5.01-00 0x00000001 0x6B65 717 0/0/0
R6.00-00 0x00000008 0x42F1 1046 0/0/0
R6.02-00 0x00000001 0x8349 907 0/0/0
R7.00-00 0x00000007 0x5BE1 1049 0/0/0
R7.02-00 0x00000001 0x5775 1026 0/0/0
R7.03-00 0x00000002 0x992E 1049 0/0/0
如果ATT位设置为1,集成IS-IS就会增加一条到达最近的L1/L2路由器的IP缺省路由
r1(config)#router isis
r1(config-router)#is-type level-1 (把路由器变成区域内路由器,默认是level-1-2)
r1(config-router)#int f0/0.12
r1(config-subif)#isis circuit-type level-1(把链路变成L1,不等同于上述配置)
r3#show clns protocol
IS-IS Router: <Null Tag>
System Id: 1111.1111.1111.00 IS-Type: level-1
Manual area address(es):
49.0012
Routing for area address(es):
49.0012
No interfaces in domain/area.
Redistribute:
static (on by default)
Distance for L2 CLNS routes: 110
RRR level: none
Generate narrow metrics: level-1-2
Accept narrow metrics: level-1-2
Generate wide metrics: none
Accept wide metrics: none
r1#show isis database中的ATT(相当于ABR的标识位)
r3(config-router)#redistribute isis ip level-2 into level-1 100 (isis是自己重分布自己)
r3(config)#access-list 100 permit ip any any
重分布进来的路由会显示为ia:IS-IS
删除ATT位产生的默认路由
R1(config-router)#set-attached-bit route-map A
==========================================================
R1==============================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
clns routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip router isis
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.14
encapsulation dot1Q 14
ip address 14.1.1.1 255.255.255.0
ip router isis
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
ip address 12.1.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
clns router isis
frame-relay map ip 12.1.1.2 102 broadcast
frame-relay map clns 102 broadcast
no frame-relay inverse-arp
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.1111.0000.0000.0001.00
is-type level-1
!
no ip http server
ip classless
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2========================================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
clns routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 23.1.1.2 255.255.255.0
ip router isis
!
interface FastEthernet0/0.25
encapsulation dot1Q 25
ip address 25.1.1.2 255.255.255.0
ip router isis
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
ip address 12.1.1.2 255.255.255.0
ip router isis
encapsulation frame-relay
serial restart-delay 0
clns router isis
frame-relay map clns 201 broadcast
frame-relay map ip 12.1.1.1 201 broadcast
no frame-relay inverse-arp
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.1111.0000.0000.0002.00
is-type level-1-2 backdoor
redistribute isis ip level-2 into level-1 distribute-list 100
!
ip http server
ip classless
!
!
access-list 100 permit ip any any
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R3=================================================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 23.1.1.3 255.255.255.0
ip router isis
!
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 34.1.1.3 255.255.255.0
ip router isis
!
interface FastEthernet0/0.37
encapsulation dot1Q 37
ip address 37.1.1.3 255.255.255.0
ip router isis
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.1111.0000.0000.0003.00
is-type level-1-2 backdoor
redistribute isis ip level-2 into level-1 distribute-list 100
!
ip http server
ip classless
!
!
access-list 100 permit ip any any
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R4=============================================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip router isis
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.14
encapsulation dot1Q 14
ip address 14.1.1.4 255.255.255.0
ip router isis
!
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 34.1.1.4 255.255.255.0
ip router isis
!
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 45.1.1.4 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.1111.0000.0000.0004.00
is-type level-1
!
ip http server
ip classless
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R5==============================================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip router isis
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.25
encapsulation dot1Q 25
ip address 25.1.1.5 255.255.255.0
ip router isis
!
interface FastEthernet0/0.56
encapsulation dot1Q 56
ip address 56.1.1.5 255.255.255.0
ip router isis
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.2222.0000.0000.0005.00
!
ip http server
ip classless
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R6======================================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip router isis
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.56
encapsulation dot1Q 56
ip address 56.1.1.6 255.255.255.0
ip router isis
!
interface FastEthernet0/0.67
encapsulation dot1Q 67
ip address 67.1.1.6 255.255.255.0
ip router isis
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.2222.0000.0000.0006.00
!
ip http server
ip classless
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R7=======================================
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.37
encapsulation dot1Q 37
ip address 37.1.1.7 255.255.255.0
ip router isis
!
interface FastEthernet0/0.67
encapsulation dot1Q 67
ip address 67.1.1.7 255.255.255.0
ip router isis
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.2222.0000.0000.0007.00
!
ip http server
ip classless
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end