多校4 1001 Olympiad

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1118    Accepted Submission(s): 664


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab). Please be fast to get the gold medal!
 

 

Input
The first line of the input is a single integer T (T1000), indicating the number of testcases. 

For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1ab100000.
 

 

Output
For each testcase, print one line indicating the answer. 
 

 

Sample Input
2 1 10 1 1000
 

 

Sample Output
10 738
#include<cstdio>
int a[100005];
int num[10];
int main()
{
    int T, t, f, l, r;
    a[0] = 0;
    for(int i = 1; i <= 100000; i++){
        for(int j = 0; j < 10; j++){
            num[j] = 0;
        }
        f = 0;
        t = i;
        while(t != 0){
            if(num[t % 10] == 1){
                f = 1;
                break;
            }
            else{
                num[t % 10] = 1;
            }
            t = t / 10;
        }
        if(f == 0){
            a[i] = a[i-1] + 1;
        }
        else{
            a[i] = a[i-1];
        }
    }
    scanf("%d", &T);
    while(T--){
        scanf("%d%d", &l, &r);
        printf("%d\n", a[r] - a[l-1]);
    }
}
View Code

 

posted @ 2015-08-30 19:00  cyd2014  阅读(145)  评论(0编辑  收藏  举报