HDU 1856 More is better(并查集 很好的基础题)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 5172    Accepted Submission(s): 1939


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

Author
lxlcrystal@TJU
 

Source
 

在网上看到有人把MAXN设为100001,我个人认为是不正确的,这只是n的上限,不是boys编号的上限。

AC code:

#include <iostream>
#include <cstdio>
using namespace std;

const int MAXN=10000001;
//ancestor存储祖先,counter存储有共同祖先的后代个数
int ancestor[MAXN],counter[MAXN];

//寻找祖先
int Find_Ancestor(int x)
{
    if(x!=ancestor[x])
    {
        ancestor[x]=Find_Ancestor(ancestor[x]);
    }
    return ancestor[x];
}

int main()
{
    int n,a,b,A,B,j,i,max;
    while(scanf("%d",&n)!=EOF)
    {
        //n为0时max=1
        if(n==0) max=1;
        else
        {
            //初始化
            max=0;j=0;
            for(i=1;i<=MAXN;i++)
            {
                ancestor[i]=i;
                counter[i]=1;
            }
            //边输入边处理
            for(i=1;i<=n;i++)
            {
                scanf("%d%d",&a,&b);
                //j记录所有的friend-pairs中的最大编号
                if(a>j) j=a;
                if(b>j) j=b;
                A=Find_Ancestor(a);
                B=Find_Ancestor(b);
                //重点
                if(A!=B)
                {
                    //比较祖先的后代数
                    if(counter[A]>=counter[B])
                    {
                        //合并祖先
                        ancestor[B]=A;
                        //后代数叠加
                        counter[A]+=counter[B];
                    }
                    else
                    {
                        ancestor[A]=B;
                        counter[B]+=counter[A];
                    }
                }
            }
            //查找最大值,循环到i=j即可
            for(i=1;i<=j;i++)
            {
                if(counter[i]>max)
                {
                    max=counter[i];
                }
            }
        }
        printf("%d\n",max);
    }
    return 0;
}


posted on 2012-04-18 23:50  铁树银花  阅读(192)  评论(0编辑  收藏  举报

导航