<poj,sicily>Anti-prime Sequences (DFS)

1002. Anti-prime Sequences
 
 
Total: 3346 Accepted: 1220 Rating:
3.5/5.0(54 votes)
 
     
     
 
Time Limit: 3sec    Memory Limit:32MB
Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9.

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output No anti-prime sequence exists.

Sample Input
Copy sample input to clipboard
1 10 2
1 10 3
1 10 5
40 60 7
0 0 0
Sample Output
1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

AC code

#include <iostream>
#include <cstdio>
#include <memory.h>
using namespace std;

int ans[1000],m,n,d,len;//len为sequence的长度,就是m-n+1
bool flag,vis[1001],composite[10000]={1,1};//flag用于判断是否生成anti-prime sequence

//筛选素数,composite[i]=1当且仅当i不是素数
void InitComposite()
{
    for(int i=2;i<1001;i++)
    {
        if(!composite[i])
        {
            for(int j=2;j*i<10000;j++)
                composite[i*j]=1;
        }
    }
    //for(int i=0;i<100;i++) cout<<i<<":"<<composite[i]<<" ";
}

//检查sum是否是composite number
bool CheckSum(int idx)
{
    int sum=ans[idx];
    for(int i=idx-1;i>-1&&i>idx-d;i--)
    {
        sum+=ans[i];
        if(!composite[sum]) return 0;
    }
    return 1;
}

//depth记录当前有多少个数成功加入sequence
void DFS(int depth)
{
    //当depth大于len时,代表找到anti-prime sequence
    if(depth==len)
    {
        flag=1;
        return ;
    }
    else
    {
        for(int i=n;i<=m;i++)
        {
            if(!vis[i])
            {
                ans[depth]=i;
                if(CheckSum(depth))
                {
                    vis[i]=1;
                    //ans中第depth个数已经确定,往depth+1处搜索
                    DFS(depth+1);
                    vis[i]=0;//不要漏了这个!!!
                    if(flag) return ;
                }
            }
        }
    }
    return ;
}

int main()
{
    InitComposite();
    while(scanf("%d%d%d",&n,&m,&d) && m)
    {
        memset(vis,0,sizeof(vis));
        len=m-n+1;
        flag=0;
        DFS(0);
        if(flag)
        {
            for(int i=0;i<len-1;i++)
                printf("%d,",ans[i]);
            printf("%d\n",ans[len-1]);
        }
        else puts("No anti-prime sequence exists.");
    }
    return 0;
}


 

posted on 2012-07-24 20:58  铁树银花  阅读(267)  评论(0编辑  收藏  举报

导航