程帅霞

不断受挫,不停起身,不断追寻,不止AC~~

导航

I - I(Highways)

N个点,给你N个点的坐标,现在还有Q条边已经连接好了。问把N个点怎么连接起来的花费的距离最短?
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
 
Flatopia岛国完全平坦。不幸的是,Flatopia的公共高速公路系统非常糟糕。弗拉托利亚政府意识到了这个问题,并且已经建造了一些连接一些最重要城镇的高速公路。但是,仍有一些城镇无法通过高速公路抵达。有必要建造更多的高速公路,以便能够在不离开高速公路系统的情况下在任何一对城镇之间行驶。
Flatopian城镇的编号从1到N,城镇i的位置由笛卡尔坐标(xi,yi)给出。每条高速公路连接两个城镇。所有高速公路(原始高速公路和要建造的高速公路)都遵循直线,因此它们的长度等于城镇之间的笛卡尔距离。所有高速公路都可以在两个方向上使用。高速公路可以自由地相互交叉,但司机只能在位于两条高速公路尽头的小镇的高速公路之间切换。
Flatopian政府希望最大限度地降低建设新高速公路的成本。但是,他们希望保证每个城镇都可以从其他城镇到达公路。由于Flatopia是如此平坦,高速公路的成本总是与其长度成正比。因此,最便宜的高速公路系统将是最小化总公路长度的系统。

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define inf 0x7fffffff
int dp[1010][1010],vis[1010],dis[1010],f[1010];
int x[1010],y[1010],m,n;
void djk()
{
    int i,j;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
    {
        dis[i]=dp[1][i];//假设所有城镇都是与1号城镇连接最优;其实和dis数组一个意思,后面也一样更新
        f[i]=1;
    }
    dis[1]=0;
    vis[1]=1;
    for(int i=1;i<=n;i++)
    {
        int k=0,minn=inf;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&minn>dis[j])
            {
                minn=dis[j];
                k=j;
            }
        }
        vis[k]=1;
        if(dp[f[k]][k]!=0) //输出所有距离不为0相连的城镇即为需要建设的道路
            printf("%d %d\n",k,f[k]);//不是已经建好的路就输出当前建立的边
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]>dp[k][j])
            {
                dis[j]=dp[k][j];//当有更优的路线到v城镇更新距离,更新与v城镇相连的城镇号
                f[j]=k;
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        int i,j,a,b;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            for(int j=1;j<=i;j++)
                dp[i][j]=dp[j][i]=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            dp[a][b]=dp[b][a]=0;//城镇间已有公路距离为0
        }
        djk();
    }
}

 

方法2:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct A
{
    int a;
    int b;
    double c;
}q[1000010];
double cmp(struct A x,struct A y)
{
    return x.c<y.c;
}
int f[10010],a[10010],b[10010];
int getf(int i)
{
    if(f[i]==i)
        return i;
    else
    {
        f[i]=getf(f[i]);
        return f[i];
    }
}
int merge(int v,int u)
{
    int t1,t2;
    t1=getf(u);
    t2=getf(v);
    if(t1!=t2)
    {
        f[t1]=t2;
        return 1;
    }
    return 0;
}
 
int main()
{
    int n,m,x,y,i,j,v,t,cut;
    scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d%d",&a[i],&b[i]);
        v=1;
        for(i=1;i<n;i++)//存储路径 
            for(j=i+1;j<=n;j++)
            {
                q[v].a=i;
                q[v].b=j;
                q[v].c=(double)sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
                v++;
            }
        v=v-1;
        sort(q+1,q+v+1,cmp);
        for(i=1;i<=n;i++)
            f[i]=i;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            merge(x,y);//查找是否为共同祖先,赋给共同祖先 
        }
        cut=0;
        for(i=1;i<=v;i++)
        {
            if(merge(q[i].a,q[i].b))//若不是一个共同祖先说明两城镇间未连接为需要建设的城镇 
            {                        //存储两城镇 
                a[cut]=q[i].a;
                b[cut]=q[i].b;
                cut++;
            }
            if(cut==n-1)//这个判断只是为了提前结束循环,不加也能AC 
                break;
        }
        for(i=0;i<cut;i++)
            printf("%d %d\n",a[i],b[i]);
    return 0;
}

 



posted on 2020-08-05 21:54  程帅霞  阅读(1005)  评论(0编辑  收藏  举报