程帅霞

不断受挫,不停起身,不断追寻,不止AC~~

导航

A - The Suspects (sars传染)

题意:有m组,0为起点,有0的那一组全是嫌疑人,之后会不断传递到其它组去,问一共有多少人是嫌疑人

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<functional>
#include<string>
#include<queue>
#include<set>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
#define ll long long 
#define inf 0x3f3f3f3f
int n,m,pre[30005],a[30005];
int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x]);
 } 
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        pre[fx]=fy;
}
int main()
{
    while(cin>>n>>m&&(n+m))
    {
        for(int i=0;i<n;i++)//每人一个父节点 
        pre[i]=i;
        for(int i=0;i<m;i++)
        {
            int k;
            cin>>k;
            cin>>a[0]; 
            for(int j=1;j<k;j++)
            {
                cin>>a[j];
                merge(a[0],a[j]);
                //因为每一行都是有关系的,
                //将每一行关联起来。 
            }
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            if(find(i)==pre[0])//判断0和第i个人是否有关系 
            ans++;
        }
        printf("%d\n",ans);
    }
 } 

 

posted on 2020-07-27 10:05  程帅霞  阅读(394)  评论(0编辑  收藏  举报