UVA-11995

There is a bag-like data structure, supporting two operations:1 x Throw an element x into the bag.2 Take out an element from the bag.Given a sequence of operations with return values, you’re going to guess the data structure. It isa stack (Last-In, First-Out), a queue (First-In, First-Out), a priority-queue (Always take out largerelements first) or something else that you can hardly imagine!InputThere are several test cases. Each test case begins with a line containing a single integer n (1 ≤ n ≤1000). Each of the next n lines is either a type-1 command, or an integer 2 followed by an integer x.That means after executing a type-2 command, we get an element x without error. The value of xis always a positive integer not larger than 100. The input is terminated by end-of-file (EOF).OutputFor each test case, output one of the following:stack It’s definitely a stack.queue It’s definitely a queue.priority queue It’s definitely a priority queue.impossible It can’t be a stack, a queue or a priority queue.not sure It can be more than one of the three data structures mentionedabove.Sample Input61 11 21 32 12 22 361 11 21 32 32 22 121 12 241 21 12 12 271 21 51 11 32 51 42 4Sample Outputqueuenot sureimpossiblestackpriority queue


题解:分别定义 stack、queue、priority_queue 判断这个操作序列是不是符合上述结构。

AC代码为:


#include<stdio.h>  
#include<stack>  
#include<queue>  
using namespace std;  
int main()  
{  
    int n, i, x, y, f[4];  
    while(~scanf("%d",&n))  
    {  
        stack<int> s;  
        queue<int> q;  
        priority_queue<int, vector<int>, less<int> > pq;  
        for(i=0;i<3;i++) 
f[i]=1;  
        for(i=0;i<n;i++)  
        {  
            scanf("%d%d",&x,&y);  
            if(x == 1)  
            {  
                s.push(y);  
                q.push(y);  
                pq.push(y);  
            }  
            else  
            {  
                if(!s.empty())  
                {  
                    if(s.top() != y)  
                        f[0] = 0;  
                    s.pop();  
                }  
                else  
                    f[0] = 0;  
  
                if(!q.empty())  
                {  
                    if(q.front() != y)  
                        f[1] = 0;  
                    q.pop();  
                }  
                else  
                    f[1] = 0;  
  
                if(!pq.empty())  
                {  
                    if(pq.top() != y)  
                        f[2] = 0;  
                    pq.pop();  
                }  
                else  
                    f[2] = 0;  
            }  
        }  
        int num = 0;  
        for(i = 0; i < 3; i++)  
            if(f[i] == 1)  
                num++;  
        if(num == 0)  
            printf("impossible\n");  
        else if(num > 1)  
            printf("not sure\n");  
        else  
        {  
            if(f[0] == 1)  
                printf("stack\n");  
            else if(f[1] == 1)  
                printf("queue\n");  
            else  
                printf("priority queue\n");  
        }  
    }  
    return 0;  
}  


posted @ 2018-01-24 22:37  StarHai  阅读(295)  评论(0编辑  收藏  举报