UVA 147Dollars

B - Dollars
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

 

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 tex2html_wrap_inline25 20c, 2 tex2html_wrap_inline25 10c, 10c+2 tex2html_wrap_inline25 5c, and 4 tex2html_wrap_inline25 5c.

 

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

 

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

 

Sample output

  0.20                4
  2.00              293

题意是 有不同价值的美元, 你用这些美元组成需要金额, 问你能组成多少种。
这是个背包问题, 该问题的转移方程是dp[j] = dp[j] + dp[j - a[i]]; j为目前的金额, a[]各个金额美元的价值
最后要注意输出的格式

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 6002;
int main()
{
    int a[] = {1, 2, 4, 10, 20, 40, 100, 200, 400, 1000, 2000};
    long long int dp[maxn];
    int  m;
    double n;
    while(cin >> n){
        m = n * 20;
        if(m == 0) break;
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        for(int i = 0; i < 11; i++){
            for(int j = a[i]; j <= m; j++){
                dp[j] = dp[j] + dp[j - a[i]];
            }
        }
        printf("%6.2f%17lld\n", n, dp[m]);
    }
    return 0;
}
View Code

 

posted on 2016-07-31 16:39  disppr  阅读(140)  评论(0编辑  收藏  举报