Monkey and Banana 背包dp

经典dp

乍看好像是完全背包 因为无限个

但是其实每个砖头只有三种情况 将这些情况都当成一个新的砖头放进brick里面就可以了

这里要注意 一开始我的判断是下面砖头的x y 分别大于 上面的 x y 这样可以 但要在加入exchange 中做点修改

使得每个brick 的 x 都小于 y

例如 brickA 3 9 12 brickB 4 2 13

则 brickA 会加入 9 12 3, 12 3 9  (旋转加入) brickB 2 13 4, 13 4 2

如果不限制 x < y  将检测不到 3 9 12和 2 4 13这种合法情况 

其实就是 你check 判断的是 x y分别是否小于 但没判断 x1 < y2 y1 < x2 的情况(交叉的情况)

故每次确定将x < y 放入队列 就排除了这些不确定 

 

View Code
Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4895    Accepted Submission(s): 2503


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
View Code
#include <stdio.h>
#include <algorithm>
#include <stack>

using std::stack;
using std::sort;
stack<int> s;
int cnt, dp[100], n;
struct node
{
    int x, y, h;
    bool operator > (node a) const
    {
        if( x == a.x )
            return y >= a.y;
        else return x > a.x ;
    }
}brick[100];
void exchange(int i)
{
    int x = brick[i].x;
    int y = brick[i].y;
    int h = brick[i].h;
    
    if( x > y )
    {
        int tmp = brick[i].x;
        brick[i].x = brick[i].y;
        brick[i].y = tmp; 
    }
    brick[++i].x = y;
    brick[i].y = h;
    brick[i].h = x;
    if( y > h )
    {
        int tmp = brick[i].x;
        brick[i].x = brick[i].y;
        brick[i].y = tmp; 
    }
    brick[++i].x = h;
    brick[i].y = x;
    brick[i].h = y;
    if( h > x )
    {
        int tmp = brick[i].x;
        brick[i].x = brick[i].y;
        brick[i].y = tmp; 
    }
}
int cmp(node a, node b)
{    return a > b; }
bool check(int i, int j)
{
    return brick[i].x < brick[j].x && brick[i].y < brick[j].y;
}
int max(int a, int b)
{ return a>=b ?a :b ; }
int main()
{
    int i, j, cas = 0;
    while(scanf("%d", &n), n)
    {
        int    maxNum = 0;
        for(i=1; i<=n*3; i+=3)
        {
            scanf("%d %d %d", &brick[i].x, &brick[i].y, &brick[i].h);
            exchange(i);
        }
        cnt = n*3;
        sort(brick+1, brick+1+cnt, cmp);
        for(i=1; i<=cnt; i++)
        {
            dp[i] = brick[i].h ;
            for(j=1; j<i; j++)
            {
                if(check(i, j))
                    dp[i] = max( brick[i].h+dp[j], dp[i] );
            }
        }
        for(i=1; i<=cnt; i++)
            if(dp[i] > maxNum )
                maxNum = dp[i];
        printf("Case %d: maximum height = %d\n", ++cas, maxNum);
    }
    return 0;
}

 

posted @ 2013-03-21 11:46  April_Tsui  阅读(203)  评论(0编辑  收藏  举报