Connect the Cities 最小生成树基础 PRIM

krusal 其实只要连接强连通图的个数-1 就可以了 我还每次都find一下他们的父亲是否一样

强连通图个数 = fa[i] == i 的个数

prim 则最主要将连通了的边权值设为0

题目:

View Code
Connect the Cities

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
Sample Output
1

code:

View Code
#include <stdio.h>
#include <algorithm>
#include <string.h>

using std::sort;
const int INF = 0x3f3f3f3f;
int n, m, t, low[505], g[505][505], sum;
bool set[505];
bool prim()
{
    memset(set, 0, sizeof(set));
    int min, pos, i, j;
    for(i=1; i<=n; i++)
        low[i] = g[1][i];
    for(i=1; i<=n; i++)
    {
        min = pos = INF ;
        for(j=1; j<=n; j++)
            if(!set[j] && low[j] < min)
                min = low[pos = j];
        if( pos == INF )
            return 0;
        set[pos] = 1, sum += min;
        for(j=1; j<=n; j++)
            if(!set[j] && low[j] > g[pos][j])
                low[j] = g[pos][j];
    }
    return 1;
}
int min(int a, int b)
{  return a<=b ?a :b ;  }
int main()
{
    int cas, i, a, b, c, k, j;
    scanf("%d", &cas);
    while( cas-- )
    {
        sum = 0;
        scanf("%d %d %d", &n, &m, &t);
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                g[i][j] = g[j][i] = i==j?0:INF;
        for(i=1; i<=m; i++)
        {
            scanf("%d %d %d", &a, &b, &c);
            g[a][b] = g[b][a] = min(g[a][b], c);  // 重边!
        }
        while( t-- )
        {
            scanf("%d", &k);
            scanf("%d", &a);
            while( --k )
            {
                scanf("%d", &b);
                g[a][b] = g[b][a] = 0;
                a = b;     // 前后设为0 就可以 不用两两设为0
            }
        }
        printf("%d\n", prim()?sum:-1);

    }
    return 0;
}

 

posted @ 2013-03-17 21:54  April_Tsui  阅读(157)  评论(0编辑  收藏  举报