2015百度之星 下棋

下棋#

 
Time Limit: 6000/3000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)

NM的棋盘上有一个受伤的国王与一个要去救援国王的骑士,他们每个单位时间必须同时移动一次寻找对方。如下图所示,黑色的图例表示国王(右)或骑士(左)当前所在的位置,那么灰色的位置表示在一次移动中他们可能到达的位置。国王伤势严重,因此他必须在K个单位时间内得到骑士的救援,否则会挂掉。问国王是否可以在K个单位时间内获得救援,如果可以,最短需要花多少个单位时间。

Input

第一行包含一个整数T,1T50代表测试数据的组数,接下来T组测试数据。

每组测试数据第一行包含三个整数N,M,K, 且2N,M10001K200。第二行两个整数Xking,Yking,对应国王所在方格的坐标。第三行两个整数Xknight,Yknight,对应骑士所在方格的坐标。其中1Xking,XknightN,1Yking,YknightM,保证骑士与国王一开始不在同一个方格内且他们都可以移动。:

Output

对于每组测试数据,输出两行:

第一行输出:"Case #i:"。i代表第i组测试数据。

第二行输出测试数据的结果,如果国王可以得到救援,则输出最快需要花多少个单位时间。否则,输出“OH,NO!”。

Sample Input
2
3 2 1
1 1
3 1
3 3 1
1 1
1 2 
Sample Output
Case #1:
1
Case #2:
OH,NO!

Problem's Link:   http://bestcoder.hdu.edu.cn/contests/contest_showproblem.php?cid=584&pid=1005
#


 

Mean: 

略。

analyse:

找规律,广搜莫名超时...

Time complexity: O(n)

 

Source code: 

 

复制代码
/*
* this code is made by crazyacking
* Verdict: Accepted
* Submission Date: 2015-05-25-14.59
* Time: 0MS
* Memory: 137KB
*/
#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#define  LL long long
#define  ULL unsigned long long
using namespace std;
int n , m , k;
int main()
{
    int t , len , cas = 0 , i , j ;
    char ch ;
    scanf( "%d", &t );
    while ( cas < t )
    {
        int x , y , xx, yy , ans , a , b ;
        cas++;
        printf( "Case #%d:\n", cas );
        scanf( "%d%d%d", &n, &m, &k );
        scanf( "%d%d", &x, &y );
        scanf( "%d%d", &xx, &yy );
        a = abs( x - xx ) ;
        b = abs( y - yy ) ;
        if ( ( a == 2 && b == 1 && ( y == 1 || y == m ) ) || ( a == 1 && b == 2 && ( x == 1 || x == n ) ) ) { ans = 2; }
        else if ( a == 1 && b == 1 && ( x == 1 || x == n ) && ( y == 1 || y == m ) ) { ans = 2 ; }
        else if ( ( a == 0 && b == 1 && ( y == 1 || y == m ) ) || ( a == 1 && b == 0 && ( x == 1 || x == n ) ) ) { ans = 2 ; }
        else {
            if ( a < b ) { int g = a ; a = b ; b = g ; }
            if ( a / 3 * 2 <= b ) {
                ans = ( a + b ) / 5 ;
                if ( ( a + b ) % 5 ) { ans ++ ; }
            }
            else { ans = a / 3 ; if ( a % 3 ) { ans ++ ; } }
        }
        if ( ans > k ) { printf( "OH,NO!\n" ); }
        else { printf( "%d\n", ans ); }
    } return 0 ;
}
View Code
复制代码
posted @   北岛知寒  阅读(340)  评论(1编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
历史上的今天:
2014-05-23 DFS or BFS --- 连通块
2014-05-23 BFS --- 模板题
2014-05-23 模拟 + 打表 --- Emag eht htiw Em Pleh
2014-05-23 模拟 + 暴搜 --- Help Me with the Game
点击右上角即可分享
微信分享提示
主题色彩