串 --- 匹配

All in All
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 27295   Accepted: 11162

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

 

【题目来源】

Ulm Local 2002

 

【题目大意】

给定一个a串和一个b串,现在要你判断a串是否出现在b串中。

 

【题目分析】

直接模拟也能过,暴力出奇迹啊,

 

复制代码
#include<string.h>
#include<stdio.h>
char a[100010],b[100010];
int main()
{
    while(scanf("%s%s",a,b)!=EOF)
    {
        int len1=strlen(a),len2=strlen(b);
        if(len1>len2)
        {
            printf("No\n");continue;
        }
        int cnt=0;
        for(int i=0;i<len2;i++)
        {
            if(a[cnt++]==b[i])
                cnt++;
        }
        if(cnt==len1)
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}
复制代码

其实这种做法是投机取巧的,数据太弱的题目能过,但是遇到数据强的就wa了。

 

 

 

 

posted @   北岛知寒  阅读(196)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
点击右上角即可分享
微信分享提示
主题色彩