(HDOJ 1020)Encoding
Encoding
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
Output
For each test case, output the encoded string in a line.
Sample Input
2 ABC ABBCCC
Sample Output
ABC A2B3C
Sample code:
#include<stdio.h>
#include<string.h>
#include<ctype.h>
char s[10010];
int main()
{
int n;
scanf("%d",&n);
getchar();
while(n--)
{
int len,i,j,count=1;
memset(s,0,sizeof(s));
scanf("%s",s);
len=strlen(s);
i=0;
j=i+1;
while(j<=len)
{
if(s[i]!=s[j])
{
if(count==1)
{
printf("%c",s[i]);
}
else
{
printf("%d%c",count,s[i]);
}
i=j;
j++;
count=1;
}
else
{
j++;
count++;
}
}
printf("\n");
}
}
#include<ctype.h>
char s[10010];
int main()
{
int n;
scanf("%d",&n);
getchar();
while(n--)
{
int len,i,j,count=1;
memset(s,0,sizeof(s));
scanf("%s",s);
len=strlen(s);
i=0;
j=i+1;
while(j<=len)
{
if(s[i]!=s[j])
{
if(count==1)
{
printf("%c",s[i]);
}
else
{
printf("%d%c",count,s[i]);
}
i=j;
j++;
count=1;
}
else
{
j++;
count++;
}
}
printf("\n");
}
}
作者:cpoint
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.