(HDOJ 1039)Easier Done Than Said?
Easier Done Than Said?
Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.
FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:
It must contain at least one vowel.
It cannot contain three consecutive vowels or three consecutive consonants.
It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.
(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:
It must contain at least one vowel.
It cannot contain three consecutive vowels or three consecutive consonants.
It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.
(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.
Sample Input
atv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
Sample Output
<a> is acceptable.<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.
Source
Sample code:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
int isvowel(char c)
{
int flag=0;
if(c=='a'||c=='e'||c=='i'||c=='o'||c=='u') flag=1;
return flag;
}
int isconsecutive(int a[],int len)
{
int i,t;
int flag=0;
for(i=0; i<len-2; i++)
{
t=a[i]+a[i+1]+a[i+2];
if((t==0)||(t==3))
{
flag=1;
break;
}
}
return flag;
}
int is_tconsecutive(char s[])
{
int i,len;
int flag=0;
len=strlen(s);
for(i=0; i<len-1; i++)
{
if((s[i]==s[i+1])&&((s[i]!='e')&&(s[i]!='o')))
{
flag=1;
break;
}
}
return flag;
}
int main()
{
char str[21];
scanf("%s",str);
while(strcmp(str,"end"))
{
int i;
int len,a[20];
int flag=0;
len=strlen(str);
for(i=0; i<len; i++)
{
if(isvowel(str[i]))
{
a[i]=1;
if(!flag)
{
flag=1;
}
}
else
{
a[i]=0;
}
}
if(!flag)
{
printf("<%s> is not acceptable.\n",str);
}
else if(isconsecutive(a,len))
{
printf("<%s> is not acceptable.\n",str);
}
else if(is_tconsecutive(str))
{
printf("<%s> is not acceptable.\n",str);
}
else
{
printf("<%s> is acceptable.\n",str);
}
memset(str,0,sizeof(str));
scanf("%s",str);
}
return 0;
}
#include<string.h>
#include<stdlib.h>
int isvowel(char c)
{
int flag=0;
if(c=='a'||c=='e'||c=='i'||c=='o'||c=='u') flag=1;
return flag;
}
int isconsecutive(int a[],int len)
{
int i,t;
int flag=0;
for(i=0; i<len-2; i++)
{
t=a[i]+a[i+1]+a[i+2];
if((t==0)||(t==3))
{
flag=1;
break;
}
}
return flag;
}
int is_tconsecutive(char s[])
{
int i,len;
int flag=0;
len=strlen(s);
for(i=0; i<len-1; i++)
{
if((s[i]==s[i+1])&&((s[i]!='e')&&(s[i]!='o')))
{
flag=1;
break;
}
}
return flag;
}
int main()
{
char str[21];
scanf("%s",str);
while(strcmp(str,"end"))
{
int i;
int len,a[20];
int flag=0;
len=strlen(str);
for(i=0; i<len; i++)
{
if(isvowel(str[i]))
{
a[i]=1;
if(!flag)
{
flag=1;
}
}
else
{
a[i]=0;
}
}
if(!flag)
{
printf("<%s> is not acceptable.\n",str);
}
else if(isconsecutive(a,len))
{
printf("<%s> is not acceptable.\n",str);
}
else if(is_tconsecutive(str))
{
printf("<%s> is not acceptable.\n",str);
}
else
{
printf("<%s> is acceptable.\n",str);
}
memset(str,0,sizeof(str));
scanf("%s",str);
}
return 0;
}
作者:cpoint
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.