(HDOJ 1021)Fibonacci Again
Fibonacci Again
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
Author
Leojay
Recommend
JGShining
AC code:
#include <iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
int k = n % 8;
if(k==2 || k==6)
{
cout<<"yes"<<endl;
}
else
cout<<"no"<<endl;
}
return 0;
using namespace std;
int main()
{
int n;
while(cin>>n)
{
int k = n % 8;
if(k==2 || k==6)
{
cout<<"yes"<<endl;
}
else
cout<<"no"<<endl;
}
return 0;
作者:cpoint
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.