poj 2230

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1
真的蠢,这道题就是一个欧拉回路模板,如何打印所有欧拉回路呢,其实只要记录节点就行了啊,一直从一个节点dfs'下去,这样由于这是一个稀疏图,他的复杂度是很低的,dfs没毛病啊,那时候全部想歪了,自己把自己
搞的很复杂,其实真的很简单。
#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
struct node{
    int ok;
    int to; 
};
vector<node> g[10002];
void dfs(int u)
{
    for(int i=0;i<g[u].size();i++)
    {
        if(g[u][i].ok==0)
        {
            g[u][i].ok=1;
            dfs(g[u][i].to);
        }
    }
    printf("%d\n",u);
}
int main()
{
    int n,m;
    cin>>n>>m;
    for(int i=0;i<m;i++)
    {
        int from,to;
        cin>>from>>to;
        g[from].push_back((node){0,to});
        g[to].push_back((node){0,from});
    }
    dfs(1);
} 

 

posted @ 2019-07-13 13:47  coolwx  阅读(110)  评论(0编辑  收藏  举报