F(x)

Problem Description
For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)
 
Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 
Sample Input
3
0 100
1 10
5 100
 
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13
 
Source

 

#include <stdio.h>
#include <vector>
#include <string.h>
using namespace std;
vector <int> num;
int dp[11][10000];
//dp状态设计成dp[pos][remain],remain表示还剩多少fA可以分配
int dfs(int pos, int remain, bool limit) //limit表示后面的数是否能乱填
{
    if (pos == -1) return remain >= 5000;
    if (!limit && ~dp[pos][remain]) return dp[pos][remain];
    int end = limit?num[pos]:9;
    int res = 0;
    for (int i = 0; i <= end; i ++)
    {
        res += dfs(pos-1, remain-(1<<pos)*i, limit && (i == end));
    }
    if (!limit) dp[pos][remain] = res;
    return res;
}

int main()
{
    int t;
    scanf("%d", &t);
    memset(dp, -1,sizeof(dp));
    for (int ca = 1; ca <= t; ca ++)
    {
        int A, B;
        scanf("%d %d", &A, &B);
        num.clear();
        while(B)
        {
            num.push_back(B % 10);
            B /= 10;
        }
        int fa = 0;
        for (int i = 0; A; A /= 10, ++ i) fa += (1 << i) * (A % 10);
        printf("Case #%d: %d\n", ca, dfs(num.size()-1, 5000+fa, 1));
    }
    return 0;
}
数位DP模板(HDU 4734)

 

posted @ 2013-09-16 19:55  1002liu  阅读(302)  评论(0编辑  收藏  举报