Good Numbers

Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).
 
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 
Sample Input
2 1 10 1 20
 
Sample Output
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
#include<cstdio>

__int64 sum(__int64 b)
{
    int flag=0;
    __int64 s=b,sb;
    __int64 sum=0;
    while(s!=0)
    {
        sum+=s%10;
        s/=10;
    }
    sum=sum-b%10;
    sum%=10;
    if(sum==0 || sum+b%10>=10) flag=0;
    else flag=1;
    sb=b/10-flag;
    return sb;
}

int main()
{
    __int64 a,b;
    int t,step=1,k;
    scanf("%d",&t);
    while(t--)
    {
        k=0;
        scanf("%I64d%I64d",&a,&b);
        if(a==0) k=1;
        printf("Case #%d: %I64d\n",step++,sum(b)-sum(a-1)+k);
    }
    return 0;
}
数论,找规律
posted @ 2013-09-11 19:28  1002liu  阅读(196)  评论(0编辑  收藏  举报