Herding

Problem Description
Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.
 
Input
The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case.
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.
 
Output
For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.
 
Sample Input
1 4
-1.00 0.00
0.00 -3.00
2.00 0.00
2.00 2.00
 
Sample Output
2.00
 
Source
#include <cstdio>
#include <cmath>
#define min(a,b) a<b? a:b
#define maxn 305
#define INF 0x3f3f3f3f

int n,m;
double ans;
struct point
{
    double x,y;
} p[maxn],p1,p2;

point Length(point a,point b)
{
    point c;
    c.x = a.x-b.x;
    c.y = a.y-b.y;
    return c;
}

double Dot(point p1,point p2)
{
    return p1.x*p2.y-p2.x*p1.y;
}
void solve()
{
    int i,j,k,dir;
    double d1,d2,dd,t;
    for(i=1; i<=n; i++)
        for(j=i+1; j<=n; j++)
        {
            point p1 = Length(p[i],p[j]);
            for(k=j+1; k<=n; k++)
            {
                point p2 =Length(p[i],p[k]);
                double d = fabs(Dot(p1,p2));
                if(d==0) continue;
                ans=min(ans,0.5*d);
            }
        }
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1; i<=n; i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        ans=INF;
        solve();
        if(ans<INF) printf("%.2f\n",ans);
        else puts("Impossible");
    }
    return 0;
}
View Code

 

posted @ 2013-09-09 21:44  1002liu  阅读(301)  评论(0编辑  收藏  举报