< 2025年4月 >
30 31 1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 1 2 3
4 5 6 7 8 9 10

Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

------------------------------------------------------------------------------------------------------------------------------------------
这道题与递归相关,为入门级难度。对于规模递减缓慢的递归问题来说,存在的策略有三种:
1. 记忆。当情况为可数时,可以存储中间过程计算的结果,并在其他分支的迭代式遇到同样算式时直接调用结果,如本题。
2. 寻找直接求解式而非迭代式,即寻找其中的数学性质,如斐波那契数列的计算。
3. 尝试是否能够把问题转化为非递归式,如二分法。

 

复制代码
#include <stdio.h>
#include <stdlib.h>

/* Function Run Fun
/  PKU OJ
/  ID:1579
/  直接采用递归是低效的,此题采用记忆法,将计算出的中间量进行记忆,从而减少重复迭代造成的效率损失
*/

int memory[21][21][21];

int W(int a, int b, int c)
{
    if(a <= 0 || b <= 0 || c <= 0)
    {
        return 1;
    }
    else if(a > 20 || b > 20 || c > 20)
    {
        memory[20][20][20] = W(20, 20, 20);
        return memory[20][20][20];
    }
    else if((int)memory[a][b][c] != 0)
    {
        return memory[a][b][c];
    }
    else if(a < b && b < c)
    {
        memory[a][b][c - 1] = W(a, b, c - 1);
        memory[a][b - 1][c - 1] = W(a, b - 1, c - 1);
        memory[a][b - 1][c] = W(a, b - 1, c);
        return memory[a][b][c - 1] + memory[a][b - 1][c - 1] - memory[a][b - 1][c];
    }
    else
    {
        memory[a-1][b][c] = W(a - 1, b, c);
        memory[a-1][b-1][c] = W(a - 1, b-1, c);
        memory[a-1][b][c-1] = W(a - 1, b, c-1);
        memory[a-1][b-1][c-1] = W(a - 1, b-1, c-1);
        return memory[a-1][b][c] + memory[a-1][b-1][c] + memory[a-1][b][c-1] - memory[a-1][b-1][c-1];
    }
}

int main()
{
    int a[100], b[100],c[100];
    int index = 0;
    while(scanf("%d%d%d", &a[index], &b[index], &c[index]) != EOF)
    {
        if(a[index] == -1 && b[index] == -1 && c[index] == -1)
        {
            break;
        }
        index++;

    }
    int i;
    for(i = 0; i < index; i++)
    {
        printf("w(%d, %d, %d) = %d\n", a[i], b[i], c[i], W(a[i], b[i], c[i]));
    }
    return 0;
}
复制代码

 

posted on   CodingPenguin  阅读(135)  评论(0编辑  收藏  举报
编辑推荐:
· 大模型 Token 究竟是啥:图解大模型Token
· 35岁程序员的中年求职记:四次碰壁后的深度反思
· 继承的思维:从思维模式到架构设计的深度解析
· 如何在 .NET 中 使用 ANTLR4
· 后端思维之高并发处理方案
阅读排行:
· BotSharp + MCP 三步实现智能体开发
· BotSharp 5.0 MCP:迈向更开放的AI Agent框架
· 5. RabbitMQ 消息队列中 Exchanges(交换机) 的详细说明
· 【ESP32】两种模拟 USB 鼠标的方法
· 设计模式脉络
点击右上角即可分享
微信分享提示