不要过于沉溺过去,也不要过于畅想未来,把握现在!

HDU 1532 Dinic

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10242    Accepted Submission(s): 4867


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
 

 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

 

Sample Input
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

 

Sample Output
50
 

 

Source
 

 

Recommend
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int inf=0x3fffffff;
const int maxn=207;
struct Edge
{
    int cap,flow;
};
int n,m,s,t;
Edge edges[maxn][maxn];
bool vis[maxn];
int d[maxn];
int cur[maxn];
void init()
{
          memset(edges,0,sizeof(edges));
}
bool BFS()
{
    memset(vis,0,sizeof(vis));
    queue<int>Q;
    Q.push(s);
    d[s]=0;
    vis[s]=1;
    while(!Q.empty()){
        int x=Q.front();Q.pop();
        for(int i=1;i<=n;i++){
            Edge &e=edges[x][i];
            if(!vis[i]&&e.cap>e.flow){
                vis[i]=1;
                d[i]=d[x]+1;
                Q.push(i);
            }
        }
    }
    return vis[t];
}
int DFS(int u,int cp)//进行增广
{
    int tmp=cp;
    int v,t;
    if(u==n)
        return cp;
    for(v=1;v<=n&&tmp;v++)
    {
        if(d[u]+1==d[v])
        {
            if(edges[u][v].cap>edges[u][v].flow)
            {
                t=DFS(v,min(tmp,edges[u][v].cap-edges[u][v].flow));
                edges[u][v].flow+=t;
                edges[v][u].flow-=t;
                tmp-=t;
            }
        }
    }
    return cp-tmp;
}
int Maxflow()
{
    int flow=0;
    while(BFS()){
        memset(cur,0,sizeof(cur));
        flow+=DFS(s,inf);
    }
    return flow;
}
int main()
{
   //freopen("in.txt","r",stdin);
    int a,b, c;
    while(~scanf("%d%d",&m,&n)){
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            edges[a][b].cap+=c;
        }
        s=1;t=n;
        int ans=Maxflow();
        printf("%d\n",ans);
    }
    return 0;
}

 

posted @ 2015-01-30 16:46  coding_yuan  阅读(160)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!