<span style="color:#330099;">/*
C - 二分 基础
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit
Status
Description
It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.
Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.
There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.
Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).
The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.
Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).
Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.
Sample Input
sample input #1 3
2 3 9
5 sample input #2 3
2 3 6
5
Sample Output
sample output #1 3 sample output #2 2
2014.7.15
*/
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
int water[100005], cloth, k;
bool check(int m) {
int cnt = 0;
for(int i = 0; i < cloth; i++) {
if(water[i] <= m) continue;
else {
cnt += (int)ceil((double)(water[i] - m) / (k-1));//
if(cnt > m) return false;
}
}
return true;
}
int main() {
int maxi = 0;
scanf("%d", &cloth);
for(int i = 0; i < cloth; i++) {
scanf("%d", water+i);
if(water[i] > maxi) maxi = water[i];
}
scanf("%d", &k);
if(k > 1) {
int l = 1, r = maxi, mid;
while(l <= r) {
mid = (l+r) >> 1;
if(check(mid)) r = mid - 1;
else l = mid + 1;
}
printf("%d\n", l);
}
else printf("%d\n", maxi);
return 0;
}
</span>
【推荐】还在用 ECharts 开发大屏?试试这款永久免费的开源 BI 工具!
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 如何在 .NET 中 使用 ANTLR4
· 后端思维之高并发处理方案
· 理解Rust引用及其生命周期标识(下)
· 从二进制到误差:逐行拆解C语言浮点运算中的4008175468544之谜
· .NET制作智能桌面机器人:结合BotSharp智能体框架开发语音交互
· 想让你多爱自己一些的开源计时器
· Cursor预测程序员行业倒计时:CTO应做好50%裁员计划
· 大模型 Token 究竟是啥:图解大模型Token
· 用99元买的服务器搭一套CI/CD系统
· 如何在 .NET 中 使用 ANTLR4