<span style="color:#000099;">/*
D - 简单dp 例题
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit
Status
Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
By Grant Yuan
2014.7.16
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int t,n;
int a[100005];
int dp[100005];
int ct=1;
int main()
{
cin>>t;
while(t--){
cin>>n;
for(int i=1;i<=n;i++)
cin>>a[i];
memset(dp,0,sizeof(dp));
int max=-999999;
int l1,r1,l=1,r=1;
for(int i=1;i<=n;i++)
{
if(dp[i-1]>=0)
dp[i]=dp[i-1]+a[i],r=i;
else
dp[i]=a[i],l=i;
if(dp[i]>max)
max=dp[i],l1=l,r1=r;
}
if(r1<l1) r1=l1;
printf("Case %d:\n",ct++);
printf("%d %d %d\n",max,l1,r1);
if(t) cout<<endl;
}
}
</span>