不要过于沉溺过去,也不要过于畅想未来,把握现在!

POJ 2349 Prim

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9973 Accepted: 3302
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input

1
2 4
0 100
0 300
0 600
150 750
Sample Output

212.13
Source

Waterloo local 2002.09.28


/*********************************************

        author    :    Grant Yuan
        time      :    2014.7.31
        algorithm :    Prim
        source    :    POJ 2349
        
**********************************************/

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<deque>
#define INF 0x3fffffff
#define MAX 507
using namespace std;

struct point{int x;int y;};
int t,n,p;
point v[MAX];
double cost[MAX][MAX];
bool used[MAX];
double mincost[MAX];
priority_queue<double>path;

void prim()
{

   for(int i=1;i<=n;i++)
   {
       mincost[i]=INF;
       used[i]=false;
   }
   mincost[1]=0;
   for(int i=1;i<=n;i++)
   {
     double temp=INF;int k=1;
     for(int j=1;j<=n;j++)
     {
         if(!used[j]&&mincost[j]<temp)
         {
             temp=mincost[j];
             k=j;
         }
     }
     path.push(temp);
     used[k]=true;
     for(int j=1;j<=n;j++)
     {
         mincost[j]=min(mincost[j],cost[k][j]);
     }
   }
}

int main()
{
   scanf("%d",&t);
   while(t--){
    while(!path.empty())
          path.pop();
    scanf("%d%d",&p,&n);
    for(int i=1;i<=n;i++)
    {   
        scanf("%d%d",&v[i].x,&v[i].y);
    }
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
    {
        cost[i][j]=INF;
        cost[i][j]=cost[j][i]=sqrt(1.0*(v[i].x-v[j].x)*(v[i].x-v[j].x)+1.0*(v[i].y-v[j].y)*(v[i].y-v[j].y));
    }
    prim();
    for(int i=1;i<p;i++)
        path.pop();
    printf("%.2f\n",path.top());
   }
    return 0;
}


posted @ 2014-07-31 15:53  coding_yuan  阅读(150)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!