不要过于沉溺过去,也不要过于畅想未来,把握现在!

阶乘位数转化

Digits of Factorial
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit

Status
Description
Factorial of an integer is defined by the following function

f(0) = 1
f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input
Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output
For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input
5
5 10
8 10
22 3
1000000 2
0 100
Sample Output
Case 1: 3
Case 2: 5
Case 3: 45
Case 4: 18488885
Case 5: 1

 

<span style="color:#6600cc;">/****************************************

     author   :     Grant Yuan
     time     :     2014.8.5
     algrithm :     数论

*****************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>

using namespace std;

int n,t,m;
double ans;
double aa[1000007];

void add()
{
   memset(aa,0,sizeof(aa));
   for(int i=1;i<=1000007;i++)
        aa[i]=aa[i-1]+log10(i*1.0);
}

int main()
{
    scanf("%d",&t);
    add();
    for(int i=1;i<=t;i++)
    {
        scanf("%d%d",&n,&m);
        ans=aa[n]/log10(m*1.0)+1;
        printf("Case %d: %d\n",i,(int)ans);
    }
    return 0;
}
</span>


 

posted @ 2014-08-05 21:56  coding_yuan  阅读(262)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!