不要过于沉溺过去,也不要过于畅想未来,把握现在!

Light Oj 1116

Ekka Dokka
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit

Status
Description
Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output
For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input
3
10
5
12
Sample Output
Case 1: 5 2
Case 2: Impossible
Case 3: 3 4

<span style="color:#6600cc;">/****************************************

     author   :   Grant Yuan
     time     :   2014.8.6
     algorithm:   数论
     source   :   Light Oj 1116
     explain  :   如果这个数为奇数则一定不可能;
                  如果为偶数,要保证所得偶数最小,则奇数要最大
                  用原来的数不断除以2,直到所得的数为奇数,再用
                  原数除以奇数便可得到偶数;
                  
*****************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>

using namespace std;
long long n,a,b,c;

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {

        scanf("%lld",&a);
        if(a%2)
            printf("Case %d: Impossible\n",i);
        else{
            c=a;
            while(c%2==0)
            {
             c=c/2;}
            b=a/c;
            printf("Case %d: %lld %lld\n",i,c,b);
        }
    }
    return 0;
}
</span>


 

posted @ 2014-08-07 01:12  coding_yuan  阅读(178)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!