PAT A1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

复制player #1 said: "Player #2 is a werewolf.";
player #2 said: "Player #3 is a human.";
player #3 said: "Player #4 is a werewolf.";
player #4 said: "Player #5 is a human."; and
player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.
Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.
Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

实现思路:

一道狼人杀逻辑题,相信第一次做应该不少人卡住了,双循环就可以秒了,进行判断一个是狼说谎,一个是人说谎即可。

AC代码:

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
const int N=110;
vector<int> sq;
int hashT[N],n;

bool judge(int id1,int id2) {
	fill(hashT,hashT+N,1);//默认初始化都是人  1代表人 -1代表狼
	hashT[id1]=hashT[id2]=-1;
	vector<int> lie;
	for(int i=1; i<=n; i++) {
		if(sq[i]*hashT[abs(sq[i])]<0) lie.push_back(i);
	}
	if(lie.size()==2) {
		if((hashT[lie[0]]<0&&hashT[lie[1]]>=0)||(hashT[lie[0]]>=0&&hashT[lie[1]]<0)) {
			return true;
		} else return false;
	} else return false;
}

int main() {
	cin>>n;
	sq.resize(n+1);
	bool tag=false;
	for(int i=1; i<=n; i++) scanf("%d",&sq[i]);
	for(int i=1; i<=n; i++) {
		for(int j=i+1; j<=n; j++) {
			//遍历的两个人就是狼 而且固定第一个狼是说谎
			if(judge(i,j)) {
				tag=true;
				printf("%d %d",i,j);
				return 0;
			}
		}
	}
	if(!tag) printf("No Solution");
	return 0;
}
posted @   coderJ_ONE  阅读(72)  评论(0编辑  收藏  举报
编辑推荐:
· 电商平台中订单未支付过期如何实现自动关单?
· 用 .NET NativeAOT 构建完全 distroless 的静态链接应用
· 为什么构造函数需要尽可能的简单
· 探秘 MySQL 索引底层原理,解锁数据库优化的关键密码(下)
· 大模型 Token 究竟是啥:图解大模型Token
阅读排行:
· 瞧瞧别人家的限流,那叫一个优雅!
· 1.net core 工作流WorkFlow流程(介绍)
· 一文彻底搞懂 MCP:AI 大模型的标准化工具箱
· 面试官:如果某个业务量突然提升100倍QPS你会怎么做?
· .NET 平台上的开源模型训练与推理进展
点击右上角即可分享
微信分享提示