PAT A1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:

复制3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

实现思路:

题目虽然为堆,实际就是一道很简单的判断是不是堆的问题,直接热乎上代码。

AC代码:

#include <iostream>
using namespace std;
const int N=1001;
int heap[N],n,m,val;
bool tag,isMin,isMax;

void postOrder(int x) {
	if(x>m) return;
	postOrder(x*2);
	postOrder(x*2+1);
	if(!tag) printf(" ");
	tag=false;
	printf("%d",heap[x]);
}

bool judge() {
	for(int i=1; i<=m/2; i++) {
		if(isMax) {
			if(i*2<=m&&heap[i]<heap[i*2]) isMax=false;
			else if(i*2+1<=m&&heap[i]<heap[i*2+1]) isMax=false;
		} else {
			if(i*2<=m&&heap[i]>=heap[i*2]) isMin=false;
			else if(i*2+1<=m&&heap[i]>=heap[i*2+1]) isMin=false;
		}
	}
}

int main() {
	cin>>n>>m;
	while(n--) {
		for(int i=1; i<=m; i++) {
			scanf("%d",&heap[i]);
		}
		tag=true;
		isMax=isMin=false;
		if(heap[1]>=heap[2]) {
			if(3<=m&&!heap[1]>=heap[3]) isMax=false;;
			isMax=true;
		} else {
			if(3<=m&&!heap[1]<heap[3]) isMin=false;
			isMin=true;
		}
		judge();
		if(isMax) printf("Max Heap\n");
		else if(isMin) printf("Min Heap\n");
		else printf("Not Heap\n");
		postOrder(1);
		printf("\n");
	}
	return 0;
}
posted @   coderJ_ONE  阅读(37)  评论(0)    收藏  举报
编辑推荐:
· 长文讲解 MCP 和案例实战
· Hangfire Redis 实现秒级定时任务,使用 CQRS 实现动态执行代码
· Android编译时动态插入代码原理与实践
· 解锁.NET 9性能优化黑科技:从内存管理到Web性能的最全指南
· 通过一个DEMO理解MCP(模型上下文协议)的生命周期
阅读排行:
· 工良出品 | 长文讲解 MCP 和案例实战
· 多年后再做Web开发,AI帮大忙
· 记一次 .NET某旅行社酒店管理系统 卡死分析
· centos停服,迁移centos7.3系统到新搭建的openEuler
· 上周热点回顾(4.14-4.20)
点击右上角即可分享
微信分享提示