PAT A1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

实现思路:

给出一系列序列,判断是否能够成为一个拓扑序列,基本题,采用bfs,然后判断。

AC代码:

#include <iostream>
#include <vector>
using namespace std;
const int N=1010;
int in[N]= {0};//in计算入度
vector<int> G[N];//保存出度

int main() {
	int n,m,u,v;
	cin>>n>>m;
	while(m--) {
		scanf("%d%d",&u,&v);
		G[u].push_back(v);
		in[v]++;
	}
	int k,num,id,cc=0;
	cin>>k;
	for(int i=0; i<k; i++) {
		int temp[N],cnt=n;
		for(int j=0; j<N; j++) temp[j]=in[j];
		bool tag=true;
		while(cnt--) {
			scanf("%d",&id);
			for(int j=0; j<G[id].size(); j++) {
				int cid=G[id][j];
				temp[cid]--;//入度减少
			}
			if(temp[id]!=0)
				tag=false;
		}
		if(!tag) {
			if(cc>0) printf(" ");
			cc++;
			printf("%d",i);
		}
	}
	return 0;
}
posted @ 2021-03-08 21:20  coderJ_ONE  阅读(30)  评论(0编辑  收藏  举报