PAT A1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

实现思路:

题意给出每个人兴趣爱好编号,若A和B有一个共同兴趣爱好,则他们两个属于同一个社交圈子的人,显而易见使用并查集的思想进行归并统计。

AC代码:

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
const int MAXN=1010;
int father[MAXN];
vector<int> hobby[MAXN];

int findFather(int x) {
	int a=x;
	while(x!=father[x]) {
		x=father[x];
	}
	while(a!=father[a]) {//路径压缩
		int z=a;
		a=father[a];
		father[z]=x;
	}
	return x;
}

void Union(int a,int b) {//合并
	int faA=findFather(a);
	int faB=findFather(b);
	if(faA!=faB) father[faA]=faB;
}

int main() {
	for(int i=0; i<MAXN; i++) father[i]=i;
	int n,k,val,cnt=0;
	cin>>n;
	while(n--) {
		scanf("%d:",&k);
		while(k--) {
			scanf("%d",&val);
			hobby[val].push_back(cnt);
		}
		cnt++;
	}
	for(int i=1; i<MAXN; i++) {
		int temp=hobby[i].size();//超级关键要用vector数组大小size做加减时候提前用常量存着不然可能超时 
		for(int j=0; j<temp-1; j++) {
			Union(hobby[i][j],hobby[i][j+1]);
		}
	}
	unordered_map<int,int> mp;
	for(int i=0; i<cnt; i++) {
		int fid=findFather(i);
		mp[fid]++;//统计每个社交圈子的人数
	}
	vector<int> ans;
	for(auto it : mp)
		ans.push_back(it.second);
	sort(ans.begin(),ans.end(),greater<int>());
	cout<<ans.size()<<endl;
	for(int i=0; i<ans.size(); i++) {
		printf("%d",ans[i]);
		if(i<ans.size()-1) printf(" ");
	}
	return 0;
}
posted @ 2021-02-27 14:51  coderJ_ONE  阅读(45)  评论(0编辑  收藏  举报