PAT A1095 Cars on Campus (30 分)
Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (≤10^4), the number of records, and K (≤8×10^4) the number of queries. Then N lines follow, each gives a record in the format:
plate_number hh:mm:ss status
where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00
and the latest 23:59:59
; and status is either in or out.
Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.
Then K lines of queries follow, each gives a time point in the format hh:mm:ss
. Note: the queries are given in ascending
order of the times.
Output Specification:
For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.
Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09
实现思路:
题意给出车牌和进入校园或者出校园的时间,然后给出一个时间,判断当前校园内还停着的车数,这是一道模拟题,每辆车的时间用map容器进行存储。
AC代码:
#include <iostream>
#include <vector>
#include <algorithm>
#include <map>
#include <cstring>
using namespace std;
struct node {
string id,status;
int times,parkTime;
};
int N,M;
map<string,int> mp;//统计每辆车总停留时间
bool cmp(node a,node b) {
if(a.id!=b.id) return a.id<b.id;
else return a.times<b.times;
}
bool cmp2(node a,node b) {
return a.times<b.times;
}
int main() {
cin>>N>>M;
string id,status;
int hh,mm,ss,maxPark=-1;
vector<node> arr,sq;
for(int i=0; i<N; i++) {
cin>>id;
scanf("%d:%d:%d",&hh,&mm,&ss);
cin>>status;
arr.push_back(node {id,status,hh*3600+mm*60+ss,0});
}
sort(arr.begin(),arr.end(),cmp);
for(int i=0; i<arr.size()-1; i++) {
if(arr[i].id==arr[i+1].id&&arr[i].status=="in"&&arr[i+1].status=="out") {//筛选出一对对的有效数据
sq.push_back(arr[i]);
sq.push_back(arr[i+1]);
if(mp.count(arr[i].id)==0) {
mp[arr[i].id]=0;
}
mp[arr[i].id]+=arr[i+1].times-arr[i].times;//计算出每一辆车的停留总时间
}
}
int index=0,parkCarNum=0;
sort(sq.begin(),sq.end(),cmp2);//按照时间排序
vector<string> ans;
while(M--) {
scanf("%d:%d:%d",&hh,&mm,&ss);
int ansTime=hh*3600+mm*60+ss;
while(index<sq.size()&&sq[index].times<=ansTime) {
if(sq[index].status=="in") parkCarNum++;//进入校园 车辆+1
else parkCarNum--;//出校门 车辆-1
index++;
}
cout<<parkCarNum<<endl;
}
for(auto it : mp) {//统计停留时间最长的车辆
if(it.second>maxPark) {
maxPark=it.second;
ans.clear();
ans.push_back(it.first);
} else if(it.second==maxPark) ans.push_back(it.first);
}
for(int i=0; i<ans.size(); i++)
cout<<ans[i]<<" ";
printf("%02d:%02d:%02d",maxPark/3600,maxPark/60%60,maxPark%60);
return 0;
}