PAT A1089 Insert or Merge (25 分)
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6
实现思路:
排序题模拟,给出一个原始序列和结果序列,判断是通过插入排序还是归并排序得以实现的,并且给出下一轮排序的结果,本题难点是要求用非递归版本的归并算法去实现才行,小提示:再复习一下递归版的归并排序。
AC代码:
#include <iostream>
#include <vector>
using namespace std;
const int N=110;
vector<int> q1,q2,sq,ans;
int n;
bool insertSort() {
bool tag=false;
for(int i=2; i<=n; i++) {
int pos=i-1,temp=sq[i];
while(pos>0) {
if(temp<sq[pos])
pos--;
else break;
}
pos++;
for(int j=i-1; j>=pos; j--) {
sq[j+1]=sq[j];
}
sq[pos]=temp;
if(tag) {
ans=sq;
return true;
}
if(sq==q2) tag=true;
}
return false;
}
void merge(int L1,int R1,int L2,int R2) {
int temp[N]= {0},cnt=0,i=L1,j=L2;
while(i<=R1&&j<=R2) {
if(q1[i]<q1[j]) temp[cnt++]=q1[i++];
else temp[cnt++]=q1[j++];
}
while(i<=R1) temp[cnt++]=q1[i++];
while(j<=R2) temp[cnt++]=q1[j++];
for(int x=0; x<cnt; x++) q1[L1+x]=temp[x];
}
//非递归版本归并排序
void mergeSort() {
bool tag=false;
//i/2是因为最后一躺跨度i肯定要大于n
for(int i=2; i/2<=n; i*=2) {
for(int j=1; j<=n; j+=i) {
int mid=j+i/2-1;
if(mid+1<=n) {
//min函数是为了避免最后合并两个数组 剩下的最后一个数组一定小于之前合并的
merge(j,mid,mid+1,min(j+i-1,n));
}
}
if(tag) {
ans=q1;
return;
}
if(q1==q2) tag=true;
}
}
void Print() {
for(int i=1; i<ans.size(); i++) {
printf("%d",ans[i]);
if(i<ans.size()-1) printf(" ");
else printf("\n");
}
}
int main() {
cin>>n;
q1.resize(n+1);
q2.resize(n+1);
for(int i=1; i<=n; i++) scanf("%d",&q1[i]);
for(int i=1; i<=n; i++) scanf("%d",&q2[i]);
sq=q1;
if(insertSort()) {
printf("Insertion Sort\n");
} else {
printf("Merge Sort\n");
mergeSort();
}
Print();
return 0;
}