PAT 2019年秋季 7-2 Merging Linked Lists (25 分)
Given two singly linked lists L1=a1→a2→⋯→an−1→an and L2=b1→b2→⋯→bm−1→bm. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1→a2→bm→a3→a4→bm−1⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.
Input Specification:
Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1 and L2, plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is a positive integer no more than 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.
Output Specification:
For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1
Sample Output:
01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1
实现思路:
题意就是将两个链表进行合并,其中一个链表结点个数>=另一个链表结点个数的2倍,然后将结点少的链表反过来一个个结点插入长的链表中,长链表中每两个结点就插入一个短链表的结点,这里可以采用固定L1是长链表的思路去做,更加方便。
AC代码:
#include <iostream>
#include <vector>
using namespace std;
const int N=100010;
struct node {
int id,data,next;
} Node[N];
int main() {
int bg1,bg2,n,id,data,next;
cin>>bg1>>bg2>>n;
while(n--) {
scanf("%d%d%d",&id,&data,&next);
Node[id].id=id;
Node[id].data=data;
Node[id].next=next;
}
vector<int> L1,L2,temp;
while(bg1!=-1) {
L1.push_back(bg1);
bg1=Node[bg1].next;
}
while(bg2!=-1) {
L2.push_back(bg2);
bg2=Node[bg2].next;
}
if(L2.size()>=L1.size()*2) {//保证让L1比L2长
temp=L1;
L1=L2;
L2=temp;
}
int cnt=L2.size()-1,num=0;
vector<int> ans;
for(int i=0; i<L1.size(); i++) {
num++;
ans.push_back(L1[i]);
if(num>=2) {
num=0;
if(cnt>=0) ans.push_back(L2[cnt--]);
}
}
for(int i=0; i<ans.size(); i++) {
int id=ans[i];
printf("%05d %d ",id,Node[id].data);
if(i<ans.size()-1) printf("%05d\n",ans[i+1]);
else printf("-1\n");
}
return 0;
}