PAT 2019年春季 7-2 Anniversary (25 分)
Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.
Input Specification:
Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID's are distinct.
The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.
Output Specification:
First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.
Sample Input:
5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042
Sample Output:
3
150702193604190912
实现思路:
基本的排序题没有什么可说的,就注意一下要寻找年纪最大的人,在身份证出生日期那块则时间越小。
AC代码:
#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>
#include <unordered_map>
using namespace std;
vector<string> info,guest;
unordered_map<string,int> mp;
bool cmp(string s1,string s2) {
string t1,t2;
t1=s1.substr(6,8);
t2=s2.substr(6,8);
return t1<t2;
}
int main() {
cin.tie(0);
int n,m,cnt=0;
string id;
cin>>n;
while(n--) {
cin>>id;
mp[id]=1;
}
cin>>m;
while(m--) {
cin>>id;
guest.push_back(id);
if(mp.count(id)!=0) {
cnt++;//有校友来参加
info.push_back(id);//将来参加活动的校友保存到一个数组
}
}
cout<<cnt<<endl;
if(cnt==0) {
sort(guest.begin(),guest.end(),cmp);
cout<<guest[0];//如果没有校友来参加活动则输出来宾中年纪最大的人
} else {
sort(info.begin(),info.end(),cmp);
cout<<info[0];//有校友参加宴会则输出校友中年纪最大的人
}
return 0;
}