PAT A1004 Counting Leaves (30 分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
实现思路:
题意要求统计一棵树的叶子结点,两种方法都可以做,可以用DFS或者BFS,简单题
AC代码:
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
const int MAXN=110;
struct node {
int data,high;
vector<int> child;
} Tree[MAXN];
int highTest[MAXN]= {0},maxHigh=-1;
void bfs() {
queue<int> q;
Tree[1].high=1;
q.push(1);
while(!q.empty()) {
int id=q.front();
if(Tree[id].high>maxHigh) maxHigh=Tree[id].high;
if(Tree[id].child.size()==0) highTest[Tree[id].high]++;
q.pop();
for(int i=0; i<Tree[id].child.size(); i++) {
int cid=Tree[id].child[i];
Tree[cid].high=Tree[id].high+1;
q.push(cid);
}
}
}
int main() {
int n,m,id,k,cid;
cin>>n>>m;
if(n==0) {
printf("0");
return 0;
}
for(int i=0; i<m; i++) {
scanf("%d%d",&id,&k);
while(k--) {
scanf("%d",&cid);
Tree[id].data=id;
Tree[id].child.push_back(cid);
}
}
bfs();
for(int i=1; i<=maxHigh; i++) {
printf("%d",highTest[i]);
if(i<maxHigh) printf(" ");
}
return 0;
}